Login
Immutable PageDiscussionInfoAttachments

No older revisions available!

Clear message
ytoku/daily-record/2010-12-25

MMA

bazaarのインストールに失敗したとの話を、合宿の機会に調査した。

bazaarのportはdevel/bazaarとdevel/bazaar-ngの二つがあるが、WikipediaによればBazaar-NGはBazaarに改名したらしい、と当たりをつけたことが後の悲劇である。まずdevel/bazaarをインストールしようとした。

$ sudo portinstall -P devel/bazaar 2>&1 |tee  ~/bazaar-install-log
ytoku@nest Password: 
[Gathering depends for devel/bazaar ............................................................... done]
--->  Checking for the latest package of 'devel/bazaar'
--->  Found a package of 'devel/bazaar': /usr/ports/packages/All/bazaar-1.4.2_11.tbz (bazaar-1.4.2_11)
--->  Installing 'bazaar-1.4.2_11' from a package
--->  Installing archivers/xz as dependency required by bazaar-1.4.2_11
** Port marked as IGNORE: archivers/xz:
        is already in the base system
--->  Installing the new version via the package
pkg_add: package 'bazaar-1.4.2_11' conflicts with gd-2.0.35_7,1
pkg_add: -f specified; proceeding anyway
pkg_add: could not find package xz-5.0.0  (proceeding anyway)
pkg_add: warning: package 'bazaar-1.4.2_11' requires 'libksba-1.1.0', but 'libksba-1.0.8' is installed
pkg_add: warning: package 'bazaar-1.4.2_11' requires 'gnupg-2.0.16_4', but 'gnupg-2.0.16_2' is installed
pkg_add: warning: package 'bazaar-1.4.2_11' requires 'gpgme-1.3.0_1', but 'gpgme-1.3.0' is installed     
pkg_add: can't open dependency file '/var/db/pkg/xz-5.0.0/+REQUIRED_BY'!
dependency registration is incomplete
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        - archivers/xz

失敗した主要な原因はgdとのコンフリクトらしい。gdといえばphpなどで使用する画像処理ライブラリである。nestからアンインストールするわけにはいかない。 http://www.freebsd.org/cgi/query-pr.cgi?pr=147418 によればannotateという同名のコマンドをインストールしようとするらしい。 /usr/local/localをいよいよ作るときか、portのインストール時のprefixを変更できないかなどを検討した。

ここでふと、bazaarとbazaar-ngのバージョンを比較したところなんかbazaar-ngのほうがバージョン番号が大きいことに気づく。

$ cat devel/bazaar-ng/distinfo 
SHA256 (bzr-2.2.2.tar.gz) = 734ee0c3a64e7b820d6632ae0e2a4bf91add908fdebe5c82865618c38175c8e3
SIZE (bzr-2.2.2.tar.gz) = 6897175

$ cat devel/bazaar/distinfo 
MD5 (bazaar_1.4.2.tar.gz) = 6e61d7aeec990a801977ee6cdc3958d5
SHA256 (bazaar_1.4.2.tar.gz) = 4ad40013fb6572c9e7a5d14cd055ef98ca583893425c005697a5881b8ac0cc4e
SIZE (bazaar_1.4.2.tar.gz) = 6264573

本当にbazaarの方が新しいのかと疑問を抱き、bazaarに依存していそうなソフトウェアの依存関係を調べると

$ grep DEPEND devel/bzr-upload/Makefile 
BUILD_DEPENDS=  bzr:${PORTSDIR}/devel/bazaar-ng
RUN_DEPENDS=    ${BUILD_DEPENDS}

!?

実はbazaar-ngは本当に新世代だったらしい。 devel/bazaar-ngをportinstallしたところ、無事、インストールが完了した。この徒労は何だったのか。 FreeBSDのPortの名前は信用してはいけないらしい。

ytoku/daily-record/2010-12-25 (last edited 2010-12-25 05:52:13 by ytoku)